Stopped working

For general discussion of the Poker Mavens software

Re: Stopped working

Postby Kent Briggs » Thu Jan 15, 2009 6:13 pm

crundy wrote:I've also contacted my ISP to ask why it only goes wrong externally at particular times. I suspect my upload contention gets clogged at about 8pm.


On the times when it seems to be working, how many people have been logged in?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3831
Joined: Wed Mar 19, 2008 8:47 pm

Re: Stopped working

Postby crundy » Fri Jan 16, 2009 5:14 am

Kent Briggs wrote:
crundy wrote:I've also contacted my ISP to ask why it only goes wrong externally at particular times. I suspect my upload contention gets clogged at about 8pm.


On the times when it seems to be working, how many people have been logged in?


Before I started having this problem we had 10 people logged on at the same time in the evening without any trouble. Now when it goes screwy there doesn't need to be anyone logged in. We tried this morning and got three people from three different machines (two different networks, neither were on my home network) and it worked OK.
crundy
 
Posts: 23
Joined: Fri Dec 05, 2008 6:01 pm

Re: Stopped working

Postby crundy » Thu Mar 12, 2009 4:08 pm

Hi again,
OK, so eventually I moved the app onto a server at work which is an ADSL line with a 1:1 contention ratio (business park, so no-one else using it at the time). Everyone joined the server OK, but one person got timed out before the tournament and took 5 minutes before he could reconnect. About the same time my chat in the lobby was severely delayed, and when we started the tournament the other player who was having connection problems got disconnected almost straight away, and couldn't reconnect for the duration of the session.

After about 5 minutes I was getting so lagged that I couldn't play a hand and was getting timed out every turn. No-one else still in the game reported a problem, so I restarted my router and tried again. The application hung at the 'Connecting to port 8088' screen. I connected immediately to an external server I look after via RDP and connected without a problem from there, but just as I joined the server folded my last chips :(

It would seem that certain ISPs have a massive massive problem with connections to and from Poker Mavens. I have no idea why. Can anyone shed any light?

P.S. Bear in mind I was hosting the server from my home machine (on the same ISP) for about 4 games without any problems. Has one of the updates knackered something up?
crundy
 
Posts: 23
Joined: Fri Dec 05, 2008 6:01 pm

Re: Stopped working

Postby Kent Briggs » Thu Mar 12, 2009 4:31 pm

crundy wrote:It would seem that certain ISPs have a massive massive problem with connections to and from Poker Mavens.


It's just a standard TCP/IP connection so the ISP wouldn't know any difference between it and any other server. If the connection goes bad, try going to google or yahoo or other well-known sites and make sure it's not a general ISP problem. Also bring up the Windows Task Manager and make sure your CPU isn't under some kind of heavy load. Are you patched up to 2.35? I've not had any other reports recently of connection issues.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3831
Joined: Wed Mar 19, 2008 8:47 pm

Re: Stopped working

Postby crundy » Thu Mar 12, 2009 5:37 pm

Got latest version, and I had no problem RDP'ing to another server and connecting from there. Web, IMAP, and RDP is fine while the problem is occuring.
crundy
 
Posts: 23
Joined: Fri Dec 05, 2008 6:01 pm

Re: Stopped working

Postby Kent Briggs » Thu Mar 12, 2009 5:41 pm

crundy wrote:Got latest version, and I had no problem RDP'ing to another server and connecting from there. Web, IMAP, and RDP is fine while the problem is occuring.


What version of the flash player do you have? This link will show it:

http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_15507
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3831
Joined: Wed Mar 19, 2008 8:47 pm

Re: Stopped working

Postby crundy » Fri Mar 13, 2009 4:49 am

I'll check tonight. I think I'm going to switch ISPs anyway.
crundy
 
Posts: 23
Joined: Fri Dec 05, 2008 6:01 pm

Re: Stopped working

Postby crundy » Tue Mar 17, 2009 7:35 am

I think I may have found the problem and thought I'd post it here in case anyone else is having the same problem.
As we tend to play at internet peak hours (7:30 - 9:30pm) a lot of ISPs (including mine) prioritise traffic based on service. They define each service by port number ranges. The default data port (8088) is undefined by my ISP and so on my hosting package is it classed as a "Bronze" service which receives low priority at peak times.

Services such as VOIP and online gaming (such as steam) are given high priority to avoid connection problems at peak times. Therefore I've tried changing the data port to the same as SIP (5060). I'll let you know if it works next time we play.
crundy
 
Posts: 23
Joined: Fri Dec 05, 2008 6:01 pm

Re: Stopped working

Postby Kent Briggs » Tue Mar 17, 2009 9:27 am

crundy wrote:I think I may have found the problem and thought I'd post it here in case anyone else is having the same problem.
As we tend to play at internet peak hours (7:30 - 9:30pm) a lot of ISPs (including mine) prioritise traffic based on service. They define each service by port number ranges. The default data port (8088) is undefined by my ISP and so on my hosting package is it classed as a "Bronze" service which receives low priority at peak times.


Are you in the U.S.? If so, who is your ISP? And are you referring to the ISP where the game server is running or to where the players are located (or both)? How many players do you have logged in at the peak time?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3831
Joined: Wed Mar 19, 2008 8:47 pm

Previous

Return to General

Who is online

Users browsing this forum: No registered users and 14 guests

cron