Server stopped responding

Report bugs found in Poker Mavens

Re: Server stopped responding

Postby hxe » Sat May 30, 2020 1:20 am

setspike wrote:hxe - Thought I would give you a quick update.

I noticed in the WINE logs some errors regarding the audio subsystem, so I set "Play login chime" to "No". Since then no server stalls. Running almost a week now without seeing the dreaded Websocket connection error. Not sure this was the culprit, but just wanted to let you know.

- setspike


Not that I want to jinx you, but mine is already set to no.

I did discover something interesting today though.
I set up monitors for both the file port and the packet port.
Only the File port stops responding which I found interesting.

Apparently Wine doesn't make logs by default so I think I'm going to make it start logging to see if it brings up anything interesting.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby hxe » Sat May 30, 2020 3:04 pm

hxe wrote:
setspike wrote:hxe - Thought I would give you a quick update.

I noticed in the WINE logs some errors regarding the audio subsystem, so I set "Play login chime" to "No". Since then no server stalls. Running almost a week now without seeing the dreaded Websocket connection error. Not sure this was the culprit, but just wanted to let you know.

- setspike


Apparently Wine doesn't make logs by default so I think I'm going to make it start logging to see if it brings up anything interesting.


Ugh. Crashed again. Wine never complained or at least didn't dump a log file.
This time like 12 hours later. Good thing there wasn't a game running.
As much as I hate to I might go back to Windows.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby setspike » Sat May 30, 2020 5:07 pm

Ugh, sorry to hear that. Let me know if you’re interested in comparing environments and builds offline. So far, the recent build I have up on AWS has been the most stable so far. Though I did upgrade Ubuntu patches this morning and had to reboot.
setspike
 
Posts: 45
Joined: Fri Apr 03, 2020 6:32 pm

Re: Server stopped responding

Postby hxe » Sun May 31, 2020 4:25 am

setspike wrote:Ugh, sorry to hear that. Let me know if you’re interested in comparing environments and builds offline. So far, the recent build I have up on AWS has been the most stable so far. Though I did upgrade Ubuntu patches this morning and had to reboot.


Anything sensitive? We could just post on here unless there is something you wish to discuss in private.

I'm running a KVM container on 20.04 on a dedicated server at OVH.
Not sure it matters but I'm running Pro 6.18.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby setspike » Thu Jun 04, 2020 7:13 pm

EC2 instance on AWS with Ubuntu 18.04.

Single CPU with 1GB of RAM plus manually configured 3GB swap file.
Using most recent wine-stable (v5.0.1)

Curious to know what your CPU and RAM configs are.

Thanks.
setspike
 
Posts: 45
Joined: Fri Apr 03, 2020 6:32 pm

Re: Server stopped responding

Postby hxe » Sun Jun 07, 2020 8:55 pm

setspike wrote:Curious to know what your CPU and RAM configs are.


I'm currently on Wine 5.0. I haven't updated since the last update was pushed.

CPU is E3-1231 v3 virtualized through KVM.
I gave it 4GB but it uses an average of 3GB.
I have around 15 active players at any one time.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby hxe » Thu Aug 27, 2020 1:13 pm

@setspike

Have your crashes gotten worse? I was up to over once a day at the peak.
It was so bad I bit the bullet and moved back to Windows. I'm sad I missed the $40 Windows 10 Pro from PC World.
It sucks because I refuse to expose WIndows to the internet so now I have 2 VMs: A pfSense as a router and Windows 10 Pro behind it.

It was getting to be too much of a pain in the ass killing games half way through so it kind of had to be done.
Once a week was fine, but once a day not so much.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby setspike » Thu Aug 27, 2020 5:39 pm

@hxe

I have noticed a rash of Websocket Connection errors the past couple of weeks.

Its the same issue, the packet service that runs on port 8088 seems to die while the file port service (8087) is still working.

I have a script that checks port 8088 every 5 minutes and if its not up and running. The script will alert me if it goes down.

I've yet to see port 8088 go down while I'm actively hosting a game, but I also bounce my host and PMServer on the mornings when I know I'll be hosting a poker game that night.

- setspike
setspike
 
Posts: 45
Joined: Fri Apr 03, 2020 6:32 pm

Re: Server stopped responding

Postby DonnyB » Mon Sep 07, 2020 12:29 pm

@setspike @hxe

Have either of you had any success getting IPV6 working with Poker Mavens under WINE?
DonnyB
 
Posts: 11
Joined: Thu Jul 30, 2020 11:44 am

Re: Server stopped responding

Postby setspike » Mon Sep 07, 2020 6:13 pm

@DonnyB - Haven't tried. What's the need for running under IPv6?
setspike
 
Posts: 45
Joined: Fri Apr 03, 2020 6:32 pm

PreviousNext

Return to Bugs

Who is online

Users browsing this forum: No registered users and 8 guests

cron