Server stopped responding

Report bugs found in Poker Mavens

Server stopped responding

Postby hxe » Sun May 17, 2020 11:08 pm

I've had some occasional weirdness lately where the server stops accepting new connections.

Anyone still connected is fine but anyone trying to make a new connection (or restore a dropped connection) is refused.

Nothing weird in the logs. A restart fixes it.

Like my stuck tournament bug, it's not a recurring thing.
There was only 12 logged in, 51 threads, 1 table running and 6 days uptime (since it last happened).

Any thoughts?
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby Kent Briggs » Sun May 17, 2020 11:38 pm

Do you have any connection/session limits set in your Server Settings group on the System tab?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 5278
Joined: Wed Mar 19, 2008 8:47 pm

Re: Server stopped responding

Postby setspike » Mon May 18, 2020 2:34 am

hxe - also replied to your other post about taking the server offline regarding this same problem.

Believe you're also running your server on linux in the cloud. On my unix server, I see this happen when the server has been running for 3+ days. Can't find a reason why this is happening, but I'm mitigating this issue by restarting the poker server in the morning before a poker night happens.

- J
setspike
 
Posts: 45
Joined: Fri Apr 03, 2020 6:32 pm

Re: Server stopped responding

Postby hxe » Mon May 18, 2020 5:04 am

Kent Briggs wrote:Do you have any connection/session limits set in your Server Settings group on the System tab?


I don't. Based on @setspike's response though it may be an artifact of hosting on Linux.

Is there a clean way via API to restart the server?
I noticed there's a restart function but it says that it doesn't orderly shut down.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby hxe » Mon May 18, 2020 5:05 am

setspike wrote:hxe - also replied to your other post about taking the server offline regarding this same problem.

Believe you're also running your server on linux in the cloud. On my unix server, I see this happen when the server has been running for 3+ days. Can't find a reason why this is happening, but I'm mitigating this issue by restarting the poker server in the morning before a poker night happens.

- J


Thanks for this by the way.

I honestly figured it was something like that since I didn't have any issues running it on Windows.
The fun of trying to avoid running Windows eh?

Do you have a clean way of restarting or do you do it by hand?
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby hxe » Mon May 18, 2020 5:12 am

Also if there's a way to edit posts I completely missed it.

Since this is running on something completely unsupported I don't expect you to try to figure out what's breaking.
But if you're curious I'll give you anything you like in terms of logs, access, etc.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby setspike » Mon May 18, 2020 6:15 pm

I don’t have a clean way of restarting by hand. And not sure how we would restart it via API as shutting down the server would also shutdown API access. I think for those of us running the server on linux, we’re going to be a little challenged in automating or restarting programmatically.
setspike
 
Posts: 45
Joined: Fri Apr 03, 2020 6:32 pm

Re: Server stopped responding

Postby hxe » Tue May 19, 2020 3:54 pm

setspike wrote:I don’t have a clean way of restarting by hand. And not sure how we would restart it via API as shutting down the server would also shutdown API access. I think for those of us running the server on linux, we’re going to be a little challenged in automating or restarting programmatically.


There is an API call to restart the entire computer, but it doesn't cleanly shutdown PM.

I might have to resort to using something like that because it happened again after a day and Cloudflare never sent me an alert.
I was down for like 3 hours.

Either that or switch back to Windows *barf*
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby hxe » Tue May 19, 2020 6:20 pm

setspike wrote: I think for those of us running the server on linux, we’re going to be a little challenged in automating or restarting programmatically.


I think I might rig something up with UptimeRobot where the linux server crons an API call into UptimeRobot to queue the status of PM.
If it it's down, then just restart the linux server (since I have PM set to run automatically anyways)

The next time it happens I might see if PM's API works locally. If it does, I could easily just iterate anything that's running and shut it down cleanly (or as cleanly as I can). But I think if PM is "down" it's really "down" so it wouldn't respond to local API calls.

Also Kent, if you have a way of editing the title please feel free to add Linux to it. I don't think I have the capability to edit titles.
hxe
 
Posts: 71
Joined: Sat Apr 04, 2020 1:59 pm

Re: Server stopped responding

Postby setspike » Wed May 27, 2020 11:18 am

hxe - Thought I would give you a quick update.

I noticed in the WINE logs some errors regarding the audio subsystem, so I set "Play login chime" to "No". Since then no server stalls. Running almost a week now without seeing the dreaded Websocket connection error. Not sure this was the culprit, but just wanted to let you know.

- setspike
setspike
 
Posts: 45
Joined: Fri Apr 03, 2020 6:32 pm

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 9 guests

cron