Page 4 of 4

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 4:32 pm
by Kent Briggs
Bojik wrote:Just installed ssl for the poker server and it is working with a redirect for the http address to the https address in godaddy.
But API access and remote admin access are not working.
Any thoughts?
Are you using an https connection to your domain name when making your API call to the poker server?

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 4:37 pm
by Bojik
And yes, API and remote admin were both working prior to ssl install.
No changes to my firewall or any other network\server settings.

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 4:38 pm
by Bojik
yes, https call in api settings

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 4:42 pm
by Bojik
Using the API Reference Utility 1.16
I'm getting a connection error and nothing is showing up in the Maven logs. Guessing the url redirect is the issue.

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 4:51 pm
by Bojik
on server with http://127.0.0.1 is says connection closed gracefully, and with https://127.0.0.1 it says could not load ssl library.

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 5:02 pm
by Kent Briggs
Bojik wrote:Using the API Reference Utility 1.16
I'm getting a connection error and nothing is showing up in the Maven logs. Guessing the url redirect is the issue.
Make sure you put the 32-bit OpenSSL files into the folder where you have the API utility. A link to those are in the FAQ (item 17):

http://www.briggsoft.com/pmfaq.htm

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 5:03 pm
by Kent Briggs
Bojik wrote:on server with http://127.0.0.1 is says connection closed gracefully, and with https://127.0.0.1 it says could not load ssl library.
Your SSL cert is tied to your domain name so the raw IP connections will no longer work. Use the full domain name instead.

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 5:28 pm
by Bojik
I am doing that on a different computer and no go.
https://poker.mysite.com/api, was working prior to ssl setup.

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 5:34 pm
by Kent Briggs
Bojik wrote:I am doing that on a different computer and no go.
https://poker.mysite.com/api, was working prior to ssl setup.
You can email me your actual URL and I'll see how it works from here.

Re: SSL Support in Gold 4.xx

Posted: Sun Jun 27, 2021 5:54 pm
by Bojik
email sent, thx