Help diagnosing a gmail smtp problem

For general discussion of the Poker Mavens software

Help diagnosing a gmail smtp problem

Postby stamas » Fri May 02, 2014 10:34 am

I am dealing with my own server for the first time, so please bear with me.

I am having a problem sending validation emails. I configured googles smtp as described on the FAQ, and I also installed the openssl files. When I attempt to send a validation code from the login screen, I get a generic error that says "An error occurred attempting to send the validation code". Does any one know exactly what this may mean?

I am using windows Server 2012 R2 Datacenter on a VPS. It's entirely possible that I have overlooked something obvious or am not aware of any settings I have to enable on either PM or Windows.

Thank you.
stamas
 
Posts: 4
Joined: Fri May 02, 2014 10:23 am

Re: Help diagnosing a gmail smtp problem

Postby Kent Briggs » Fri May 02, 2014 10:43 am

Check the Poker Mavens Error Log. It should give a more specific error message.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3912
Joined: Wed Mar 19, 2008 8:47 pm

Re: Help diagnosing a gmail smtp problem

Postby stamas » Fri May 02, 2014 11:48 am

Thank you very much for that bit of info. The problem is:

Email Failure (Could not load SSL Library)

I'm running 64 bit 2012 Server. In my blind effort to diagnose the problem before posting this help request, I had installed both the library exe on the faq page, and manually moved the files from the zip into the PM folder. So I had them both places.

Here is what I did today:

I manually deleted the dll's from the PM folder and tried it. Restarted PM. Same error.
I manually deleted the dll's from the System32 folder and put them in the PM folder. Restarted PM. Same error.
I manually deleted the dll's from the PM folder, and I was left with no dll's anywhere.
I then downloaded the dll's again, made sure they were the exact bytes you mentioned here: http://www.briggsoft.com/forums/viewtopic.php?f=8&t=1476&p=6287&hilit=could+not+load+ssl+library#p6284. PLaced them in my PM folder. Restarted PM. Same error.

I don't know if this means anything, but the PM is installed in the x86 program files directory. There aren't two different versions of PM, x86 and 64bit, are there?

Any ideas?

Thanks again for your help.
stamas
 
Posts: 4
Joined: Fri May 02, 2014 10:23 am

Re: Help diagnosing a gmail smtp problem

Postby Kent Briggs » Fri May 02, 2014 12:16 pm

Both the 32-bit and 64-bit version of Poker Mavens will get installed in the C:\Program Files (x86)\Briggs Softworks\Poker Mavens 4\ folder. That's where you should put the libeay32.dll and ssleay32.dll files (same folder where PMServer.exe resides). There are 32-bit and 64-bit versions of OpenSSL but the 64 bit version still have the same names with the 32 in them. Are you running the 64-bit versions of Poker Mavens and OpenSSL?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3912
Joined: Wed Mar 19, 2008 8:47 pm

Re: Help diagnosing a gmail smtp problem

Postby stamas » Fri May 02, 2014 12:20 pm

I am running 64bit ssl, but I have no idea what version of PM I am running. How do I tell? I don't see anything in "About". Is it a different install file? I'll email you the link you sent me in the meantime if that helps.

Thanks.
stamas
 
Posts: 4
Joined: Fri May 02, 2014 10:23 am

Re: Help diagnosing a gmail smtp problem

Postby Kent Briggs » Fri May 02, 2014 12:38 pm

stamas wrote:I am running 64bit ssl, but I have no idea what version of PM I am running. How do I tell? I don't see anything in "About". Is it a different install file? I'll email you the link you sent me in the meantime if that helps.


Only the Gold version has a 64-bit option. It will show "64-bit" on the title bar and the server-side about dialog. The 32-bit editions don't have any distinguishing marks.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3912
Joined: Wed Mar 19, 2008 8:47 pm

Re: Help diagnosing a gmail smtp problem

Postby stamas » Fri May 02, 2014 12:52 pm

w00t, I got it!!

That was it, I needed the 32bit version of the dll's instead of the 64bit. I assumed I needed dll's to match the operating system... I was wrong.

Thanks!!
stamas
 
Posts: 4
Joined: Fri May 02, 2014 10:23 am

Re: Help diagnosing a gmail smtp problem

Postby mikey » Tue Jun 28, 2016 7:20 am

Hello,
whats your idea about this validation email error:
email failure (error connection with SSL.error:1408F10B:SSL routines:SSL3_GET_Record:wrong version number) sending validation code to user ...
how I can solvwe this issue?
we use Gold Version 64Bit on Windows 2008 R2
mikey
 
Posts: 2
Joined: Sat Jun 18, 2016 11:33 am

Re: Help diagnosing a gmail smtp problem

Postby Kent Briggs » Tue Jun 28, 2016 9:25 am

mikey wrote:whats your idea about this validation email error:
email failure (error connection with SSL.error:1408F10B:SSL routines:SSL3_GET_Record:wrong version number) sending validation code to user ...


Was that in the Poker Mavens Error Log? Are you using gmail's server? Email me your SMTP settings (without the password).
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3912
Joined: Wed Mar 19, 2008 8:47 pm


Return to General

Who is online

Users browsing this forum: No registered users and 5 guests

cron