SSL Support in Gold 4.xx

For discussion of the Poker Mavens server module and other administration topics
Kent Briggs
Site Admin
Posts: 5618
Joined: Wed Mar 19, 2008 8:47 pm

Re: SSL Support in Gold 4.xx

Post by Kent Briggs »

Bojik wrote:Just installed ssl for the poker server and it is working with a redirect for the http address to the https address in godaddy.
But API access and remote admin access are not working.
Any thoughts?
Are you using an https connection to your domain name when making your API call to the poker server?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Bojik
Posts: 66
Joined: Sat Apr 11, 2020 3:25 pm

Re: SSL Support in Gold 4.xx

Post by Bojik »

And yes, API and remote admin were both working prior to ssl install.
No changes to my firewall or any other network\server settings.
Bojik
Posts: 66
Joined: Sat Apr 11, 2020 3:25 pm

Re: SSL Support in Gold 4.xx

Post by Bojik »

yes, https call in api settings
Bojik
Posts: 66
Joined: Sat Apr 11, 2020 3:25 pm

Re: SSL Support in Gold 4.xx

Post by Bojik »

Using the API Reference Utility 1.16
I'm getting a connection error and nothing is showing up in the Maven logs. Guessing the url redirect is the issue.
Bojik
Posts: 66
Joined: Sat Apr 11, 2020 3:25 pm

Re: SSL Support in Gold 4.xx

Post by Bojik »

on server with http://127.0.0.1 is says connection closed gracefully, and with https://127.0.0.1 it says could not load ssl library.
Kent Briggs
Site Admin
Posts: 5618
Joined: Wed Mar 19, 2008 8:47 pm

Re: SSL Support in Gold 4.xx

Post by Kent Briggs »

Bojik wrote:Using the API Reference Utility 1.16
I'm getting a connection error and nothing is showing up in the Maven logs. Guessing the url redirect is the issue.
Make sure you put the 32-bit OpenSSL files into the folder where you have the API utility. A link to those are in the FAQ (item 17):

http://www.briggsoft.com/pmfaq.htm
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
Posts: 5618
Joined: Wed Mar 19, 2008 8:47 pm

Re: SSL Support in Gold 4.xx

Post by Kent Briggs »

Bojik wrote:on server with http://127.0.0.1 is says connection closed gracefully, and with https://127.0.0.1 it says could not load ssl library.
Your SSL cert is tied to your domain name so the raw IP connections will no longer work. Use the full domain name instead.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Bojik
Posts: 66
Joined: Sat Apr 11, 2020 3:25 pm

Re: SSL Support in Gold 4.xx

Post by Bojik »

I am doing that on a different computer and no go.
https://poker.mysite.com/api, was working prior to ssl setup.
Kent Briggs
Site Admin
Posts: 5618
Joined: Wed Mar 19, 2008 8:47 pm

Re: SSL Support in Gold 4.xx

Post by Kent Briggs »

Bojik wrote:I am doing that on a different computer and no go.
https://poker.mysite.com/api, was working prior to ssl setup.
You can email me your actual URL and I'll see how it works from here.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Bojik
Posts: 66
Joined: Sat Apr 11, 2020 3:25 pm

Re: SSL Support in Gold 4.xx

Post by Bojik »

email sent, thx
Post Reply