SSL install causes graphics issues on site

For discussion of the Poker Mavens server module and other administration topics

SSL install causes graphics issues on site

Postby Tuck Fheman » Thu Jul 13, 2017 6:23 am

Ok, new problem.

I probably have the SSL info wrong. Can you help me with what file names go in which area of Server Settings please?

SSL key file : Is this the .key file I created with the SSL utility on your site?

SSL certificate file: I have this as the .crt file I received from the SSL cert company.

SSL root cert file : I have this as the .ca-bundle file I received from the SSL cert company.

The files are in a Temp folder by themselves, if they need to be somewhere else, where should they be?

The site looks fine with SSL off.

As soon as I turn it on, if I go to a local version, it looks ok.

If I go to my domain name and try to login, once I get to the lobby it looks like this ...

https://s20.postimg.org/j84gbeee5/after_ssl.png

I'm lost. :/
Tuck Fheman
 
Posts: 58
Joined: Tue Jul 04, 2017 6:44 am

Re: SSL install causes graphics issues on site

Postby Tuck Fheman » Thu Jul 13, 2017 6:52 am

Perhaps I've overlooked the obvious, but I didn't want to do this until I was sure i was supposed to.

Do I need to install the SSL cert on IIS as well, is that why I'm having this issue when turning it on?

I assumed I just needed it on the PM server.
Tuck Fheman
 
Posts: 58
Joined: Tue Jul 04, 2017 6:44 am

Re: SSL install causes graphics issues on site

Postby Kent Briggs » Thu Jul 13, 2017 9:42 am

Tuck Fheman wrote:SSL key file : Is this the .key file I created with the SSL utility on your site?
SSL certificate file: I have this as the .crt file I received from the SSL cert company.
SSL root cert file : I have this as the .ca-bundle file I received from the SSL cert company.


Yes to all 3 questions.

The files are in a Temp folder by themselves, if they need to be somewhere else, where should they be?


They can be anywhere since you'll specify the full path in the setting. I prefer to put them in the program folder where PMServer.exe is located.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3820
Joined: Wed Mar 19, 2008 8:47 pm

Re: SSL install causes graphics issues on site

Postby Kent Briggs » Thu Jul 13, 2017 9:45 am

Tuck Fheman wrote:Do I need to install the SSL cert on IIS as well, is that why I'm having this issue when turning it on?


You do if you want the IIS web server to feed pages via https. The poker server is completely independent of IIS.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3820
Joined: Wed Mar 19, 2008 8:47 pm

Re: SSL install causes graphics issues on site

Postby Tuck Fheman » Thu Jul 13, 2017 10:23 am

Kent Briggs wrote:
Tuck Fheman wrote:Do I need to install the SSL cert on IIS as well, is that why I'm having this issue when turning it on?


You do if you want the IIS web server to feed pages via https. The poker server is completely independent of IIS.


Any idea what could be causing the site to appear like that if it sounds like I have things setup correctly?
Tuck Fheman
 
Posts: 58
Joined: Tue Jul 04, 2017 6:44 am

Re: SSL install causes graphics issues on site

Postby Kent Briggs » Thu Jul 13, 2017 10:33 am

Tuck Fheman wrote:Any idea what could be causing the site to appear like that if it sounds like I have things setup correctly?


Is it online now? What is the link (send via email if you're not public).
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3820
Joined: Wed Mar 19, 2008 8:47 pm

Re: SSL install causes graphics issues on site

Postby Tuck Fheman » Fri Jul 14, 2017 4:11 am

Kent Briggs wrote:
Tuck Fheman wrote:Any idea what could be causing the site to appear like that if it sounds like I have things setup correctly?


Is it online now? What is the link (send via email if you're not public).


It was Kaspersky. Works fine, sorry.
Tuck Fheman
 
Posts: 58
Joined: Tue Jul 04, 2017 6:44 am

Re: SSL install causes graphics issues on site

Postby Tuck Fheman » Fri Jul 14, 2017 4:13 am

Image

This is what Kaspersky was messing with if it helps for anyone else.
Tuck Fheman
 
Posts: 58
Joined: Tue Jul 04, 2017 6:44 am

Re: SSL install causes graphics issues on site

Postby Tuck Fheman » Fri Jul 14, 2017 4:14 am

[quote="Tuck Fheman"]Image

Fixed size, sorry.
Tuck Fheman
 
Posts: 58
Joined: Tue Jul 04, 2017 6:44 am


Return to Site Administration

Who is online

Users browsing this forum: Bing [Bot] and 2 guests

cron