Users gone from accounts after error

For discussion of the Poker Mavens server module and other administration topics

Users gone from accounts after error

Postby Tuck Fheman » Fri Jul 07, 2017 12:48 am

Prior to shutting down Poker Mavens, I had around 24 Accounts that had signed up.

When I shut PM down, it exited with an error message.

When I started PM back up, there were only 15 accounts. =/

I'm sorry I did not catch what the error message was, but if you can tell me where I can locate a log file that will help I'll paste it here.
Tuck Fheman
 
Posts: 55
Joined: Tue Jul 04, 2017 6:44 am

Re: Users gone from accounts after error

Postby Kent Briggs » Fri Jul 07, 2017 9:16 am

On the System tab, click the Help button and then "Locate data folder". There is a Logs folder with Error and Event logs inside. The only way accounts could disappear is if the program could not write to the Accounts.db database file (also located in the data folder).
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3763
Joined: Wed Mar 19, 2008 8:47 pm

Re: Users gone from accounts after error

Postby Tuck Fheman » Fri Jul 07, 2017 11:33 pm

I think I know what happened. I changed the API settings while running, then I believe I turned it off because I couldn't get what I was trying to do to work, when I went to shut down "Failed API attempt (API not enabled) error happened then a series of "AccountsThread.Execute error: Transaction is already opened." messages in the log before exit.

So I won't do that again. ;)
Tuck Fheman
 
Posts: 55
Joined: Tue Jul 04, 2017 6:44 am

Re: Users gone from accounts after error

Postby Kent Briggs » Fri Jul 07, 2017 11:46 pm

Tuck Fheman wrote:So I won't do that again.


Actually if you can duplicate that error so that I can replicate it, I could handle the error condition better.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3763
Joined: Wed Mar 19, 2008 8:47 pm

Re: Users gone from accounts after error

Postby Tuck Fheman » Mon Jul 10, 2017 4:48 am

Kent Briggs wrote:
Tuck Fheman wrote:So I won't do that again.


Actually if you can duplicate that error so that I can replicate it, I could handle the error condition better.


I'm not sure that's something I want to duplicate. :) But I get you, I'll back everything up and see if I can do it again.

I had this one last night. Probably same scenario, I edited a few fields that indicated they were editable while running (just mentioning that in case it matters) and then later I noticed these errors, and when I went to shut down PM crashed and this time I got a screenshot.

Image

Image
Tuck Fheman
 
Posts: 55
Joined: Tue Jul 04, 2017 6:44 am

Re: Users gone from accounts after error

Postby Kent Briggs » Mon Jul 10, 2017 10:11 am

Something is wrong with your file system. It's not allowing the database file to be updated. A few questions:

What version of Windows do you have?
Does it have all the latest updates?
Do you have plenty of free disk space?
Are you logged in as administrator?
Do you have any security apps like Norton running?
Have you rebooted lately?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3763
Joined: Wed Mar 19, 2008 8:47 pm

Re: Users gone from accounts after error

Postby Tuck Fheman » Mon Jul 10, 2017 9:46 pm

Kent Briggs wrote:Something is wrong with your file system. It's not allowing the database file to be updated. A few questions:

What version of Windows do you have?
Does it have all the latest updates?
Do you have plenty of free disk space?
Are you logged in as administrator?
Do you have any security apps like Norton running?
Have you rebooted lately?


Windows Server 2012 R2
Yes
Yes
Yes
Yes, but added exclusions.
Yes.
Tuck Fheman
 
Posts: 55
Joined: Tue Jul 04, 2017 6:44 am

Re: Users gone from accounts after error

Postby Kent Briggs » Mon Jul 10, 2017 11:06 pm

Tuck Fheman wrote:
Kent Briggs wrote:Do you have any security apps like Norton running?


Yes, but added exclusions.


What specifically is running?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3763
Joined: Wed Mar 19, 2008 8:47 pm

Re: Users gone from accounts after error

Postby Kent Briggs » Mon Jul 10, 2017 11:09 pm

Also, see if anything mentioned here applies:

http://www.personalcomputerfixes.com/how-to-fix-runtime-error-217/
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3763
Joined: Wed Mar 19, 2008 8:47 pm

Re: Users gone from accounts after error

Postby Tuck Fheman » Tue Jul 11, 2017 3:50 am

Kent Briggs wrote:
Tuck Fheman wrote:
Kent Briggs wrote:Do you have any security apps like Norton running?


Yes, but added exclusions.


What specifically is running?


Immunet & Malwarebytes

I've not seen a single error since.

The two times I've encountered errors was when I edited something while PM was running.

I did discover I was running low on Disk space down to 8GB available and added some more.
Tuck Fheman
 
Posts: 55
Joined: Tue Jul 04, 2017 6:44 am

Next

Return to Site Administration

Who is online

Users browsing this forum: No registered users and 3 guests