connection error

For discussion of the Poker Mavens server module and other administration topics

connection error

Postby bigboss » Fri May 20, 2011 3:18 am

HI

I have the maven poker gold version. We are installing it on VPS. but we got this problem

I have the API used in the example outlined in
http://www.briggsoft.com/docs/pmavens/API_Examples.htm. I have also used the guide to setup
the server outlined in http://www.briggsoft.com/docs/pmavens/PMHelp.htm. The server is running
and I have used the login and registration examples used. The only things I did add were the tags
to have it fit into the design. I added table row and data tags before and after the examples shown.
I commented the avatar area of the form out because I've not included any to include yet. I wanted to
get a test template finished to get the software running. Now once I got these forms completed and included the API
and information I am now getting a Error: Connection failed
Click Back Button to correct.Error in my_thread_global_end(): 1 threads didn't exit.

I cannot seem to figure out what the problem is at all. Do you happen to know how to troubleshoot this issue?

Or would you happen to have a more well written thorough guide as to how to setup the software?

Thank you
bigboss
 
Posts: 13
Joined: Fri May 20, 2011 3:00 am

Re: connection error

Postby Kent Briggs » Fri May 20, 2011 9:15 am

bigboss wrote: Now once I got these forms completed and included the API
and information I am now getting a Error: Connection failed


Usually this is a firewall issue blocking the connection between the machine hosting the PHP code and the machine running the poker server. Is your PHP code also hosted on your VPS or somewhere else? Some ISPs will have PHP/Curl setup so that outgoing connections only work on port 80 and thus if your Poker Mavens file port is 8087, that connection is blocked.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3820
Joined: Wed Mar 19, 2008 8:47 pm

Re: connection error

Postby bigboss » Fri May 20, 2011 11:18 am

Great this issue is fixed, the problem was with ports not being open

THANK YOU
Last edited by bigboss on Fri May 20, 2011 11:32 am, edited 1 time in total.
bigboss
 
Posts: 13
Joined: Fri May 20, 2011 3:00 am

Re: connection error

Postby Kent Briggs » Fri May 20, 2011 11:27 am

bigboss wrote:well, now the ports are open and working so the account was created successfully but we are still getting the my_thread_global_end() error


If I google that error I see a bunch of messages related to PHP and MySQL. Are you accessing a MySQL database somewhere in your code?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3820
Joined: Wed Mar 19, 2008 8:47 pm

Re: connection error

Postby bigboss » Fri May 20, 2011 11:33 am

kent , we did fix the issue.

THANK YOU
bigboss
 
Posts: 13
Joined: Fri May 20, 2011 3:00 am


Return to Site Administration

Who is online

Users browsing this forum: No registered users and 6 guests