Problems with WEB Site CMS changibg codes

For discussion of the Poker Mavens server module and other administration topics

Re: Problems with WEB Site CMS changibg codes

Postby fstetson » Wed Jan 26, 2011 11:15 am

Here is a screen shot of the web page with static results.
Attachments
screenshot.jpg
screenshot.jpg (51.93 KiB) Viewed 2709 times
fstetson
 
Posts: 33
Joined: Mon Jan 18, 2010 11:03 pm

Re: Problems with WEB Site CMS changibg codes

Postby Kent Briggs » Wed Jan 26, 2011 11:21 am

fstetson wrote:Nothing is showing in the event logs ether. I have also noticed the serverstats script is saying "connection failed", and I believe I have the correct connection strings.


Are you sure you don't have two copies of the poker server running at the same time? Almost sounds like you are connecting to one and checking the other.

There are two IP adddresses in the PM Server, one for internet IP, and the other is the game server IP, which I can connect to and play. From everything I have read I should be using the game server IP


If you're on a remote VPS then the Internet IP and Local IP should be the same. It's only on a residential account behind a router where the Local IP would be different (e.g., 192.168.1.*).
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3764
Joined: Wed Mar 19, 2008 8:47 pm

Re: Problems with WEB Site CMS changibg codes

Postby fstetson » Wed Jan 26, 2011 11:25 am

API document would not load as a docx, and tried everything else. The scripts are intact as provided by the download of php files in your support site, I have made only the the following edits:

API.PHP
$url = "http://192.168.2.2:8087/api"; // <-- use your game server IP
$pw = "Ha77y2008"; // <-- use your api password

LOGIN.htm
<form method="post" action="http://192.168.2.2:8087?sitepassword="3edcvfr4" " target="_blank">

NewAcct.PHP
$avatarurl = "http://192.168.2.2:8087/avatar/"; // set your url here


Once I have these wotking correctly, I'lll change password and use security "include" statement in the API.PHP file. Thanks for looking at this for me.

I am using a wireless router.
fstetson
 
Posts: 33
Joined: Mon Jan 18, 2010 11:03 pm

Re: Problems with WEB Site CMS changibg codes

Postby Kent Briggs » Wed Jan 26, 2011 11:48 am

fstetson wrote:API document would not load as a docx, and tried everything else.


You can email it to me. No need to post confidential data here publicly.

$url = "http://192.168.2.2:8087/api"; // <-- use your game server IP


This is a local area network IP. On what machine is your PHP code running? Is it also on your local network?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3764
Joined: Wed Mar 19, 2008 8:47 pm

Re: Problems with WEB Site CMS changibg codes

Postby fstetson » Wed Jan 26, 2011 11:57 am

$url = "http://192.168.2.2:8087/api"; // <-- use your game server IP


This is a local area network IP. On what machine is your PHP code running? Is it also on your local network?[/quote]


I have a laptop with PM Pro on it, and uses a wireless connection through a router. I also have a desktop unit with PM Pro on it, and it has a ethernet connection through the router as well. I just switched to the desktop unit as the game server and changed scripts to reflect the new server IP, which is running by itself. I am not running two servers at the same tie. Results are the same.
fstetson
 
Posts: 33
Joined: Mon Jan 18, 2010 11:03 pm

Re: Problems with WEB Site CMS changibg codes

Postby fstetson » Wed Jan 26, 2011 11:58 am

Does having a comcast modem matter?
fstetson
 
Posts: 33
Joined: Mon Jan 18, 2010 11:03 pm

Re: Problems with WEB Site CMS changibg codes

Postby fstetson » Wed Jan 26, 2011 12:38 pm

I apologize, I misread your post asking where I was running the PHP from, I am using my web site on a shared windows ASP.NET server: http://stetsonmgtsolutions.com
fstetson
 
Posts: 33
Joined: Mon Jan 18, 2010 11:03 pm

Re: Problems with WEB Site CMS changibg codes

Postby Kent Briggs » Wed Jan 26, 2011 1:24 pm

fstetson wrote:I apologize, I misread your post asking where I was running the PHP from, I am using my web site on a shared windows ASP.NET server: http://stetsonmgtsolutions.com


Ok, that's explains the connection problem. An external computer cannot connect directly to your local computer IPs. The numbers that start with 192.168.*.* are assigned by your local router to your local PCs. You have to use your Internet IP in your PHP scripts. Double-click the "Internet IP Address" setting in the Site Information group on Poker Maven's System tab. Then click the Lookup button. The IP it shows along with your File Port (8087) is what you use. And finally, you have to setup port forwarding in your router (file and packet ports) to let the outside world in and to tell it which local computer to connect to. Have you already done the port forwarding? Can anyone on the outside log into site?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3764
Joined: Wed Mar 19, 2008 8:47 pm

Re: Problems with WEB Site CMS changibg codes

Postby fstetson » Wed Jan 26, 2011 2:00 pm

Kent Briggs wrote:
fstetson wrote:I apologize, I misread your post asking where I was running the PHP from, I am using my web site on a shared windows ASP.NET server: http://stetsonmgtsolutions.com


Ok, that's explains the connection problem. An external computer cannot connect directly to your local computer IPs. The numbers that start with 192.168.*.* are assigned by your local router to your local PCs. You have to use your Internet IP in your PHP scripts. Double-click the "Internet IP Address" setting in the Site Information group on Poker Maven's System tab. Then click the Lookup button. The IP it shows along with your File Port (8087) is what you use. And finally, you have to setup port forwarding in your router (file and packet ports) to let the outside world in and to tell it which local computer to connect to. Have you already done the port forwarding? Can anyone on the outside log into site?



I cannot connect using the Internet IP after lookup. Not sure how to configure port forwarding...as far as I know no one can connect, as I have not opened this to my users yet.
fstetson
 
Posts: 33
Joined: Mon Jan 18, 2010 11:03 pm

Re: Problems with WEB Site CMS changibg codes

Postby Kent Briggs » Wed Jan 26, 2011 2:20 pm

fstetson wrote:I cannot connect using the Internet IP after lookup. Not sure how to configure port forwarding...as far as I know no one can connect, as I have not opened this to my users yet.


Your router is a hardware firewall that automatically blocks all incoming connections. The exact steps for port forwarding depend on your particular router. See "Firewalls and Routers" in the Technical Information section of the Poker Mavens help file. It's also online here:

http://www.briggsoft.com/docs/pmavens/PMHelp.htm
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3764
Joined: Wed Mar 19, 2008 8:47 pm

PreviousNext

Return to Site Administration

Who is online

Users browsing this forum: No registered users and 7 guests

cron