TableGraphic API error

For general discussion of the Poker Mavens software

TableGraphic API error

Postby madcow » Sun Jul 12, 2009 9:43 am

Hi Kent,

for the 2.50, i used to able to set the backgraphic or the card graphic by API, but i can't now .. it say read-only and gave me an error .. i had to turn off the server in order to change these setting and this is no good for me, since users on the server 24/7 and you need to change the card card or the background .. i was able to do this on last version .. please make this available if possible

example:
SystemSet&Property=CardBackGraphic&Value=C:\avatar\blue.swf"

thanks
madcow
 
Posts: 196
Joined: Fri May 22, 2009 1:25 pm

Re: TableGraphic API error

Postby Kent Briggs » Sun Jul 12, 2009 10:38 am

madcow wrote:for the 2.50, i used to able to set the backgraphic or the card graphic by API, but i can't now .. it say read-only and gave me an error .. i had to turn off the server in order to change these setting and this is no good for me, since users on the server 24/7 and you need to change the card card or the background .. i was able to do this on last version .. please make this available if possible


I had to change the graphics settings so they can only be changed when offline to solve the caching issue. The server now calculates a CRC value for all the graphics when it goes online and those are passed to the client so they can be embedded in the URL used to fetch them from the server. That ensures the browser will pull the new images when they've changed since the last login, and that everyone online is getting the same images. The graphics can't be changed past that point because they won't match the CRC values. It was unlikely anyone using IE was seeing your graphics changes anyway because of the browser cache.

Why do you need to change the card graphic so often?
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3820
Joined: Wed Mar 19, 2008 8:47 pm

Re: TableGraphic API error

Postby madcow » Sun Jul 12, 2009 12:30 pm

hi,
oh ok. that's fine .
madcow
 
Posts: 196
Joined: Fri May 22, 2009 1:25 pm

Re: TableGraphic API error

Postby madcow » Sun Jul 12, 2009 6:34 pm

Hi Kent,

Can we have a beep sound a little louder ? a little sharper ..

thanks
madcow
 
Posts: 196
Joined: Fri May 22, 2009 1:25 pm

Re: TableGraphic API error

Postby Kent Briggs » Sun Jul 12, 2009 7:04 pm

madcow wrote:Can we have a beep sound a little louder ? a little sharper ..


I think I just used a standard Windows beep for that. It should be about the same volume as the other sound effects.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3820
Joined: Wed Mar 19, 2008 8:47 pm


Return to General

Who is online

Users browsing this forum: No registered users and 8 guests

cron