Wierd Problem !

Report bugs found in Poker Mavens

Wierd Problem !

Postby khaznadar » Fri May 28, 2010 8:27 am

Hey Kent,

My site got disconnected today of a Plesk error it was giving "Service Unavailable" but this is not the problem as this issue was quickly fixed, but the real problem was while I was browsing the accounts of my users I found that there was missing account and wrong accounts, after I checked very well I found out that the game is giving me info about the accounts dated 19-05-2010 which is a disaster !!

Those whose account was 0 now its loaded with hundred of dollars bought back at that date (19-5)....

Anyway, after I browsed the Accounts (.dat) found on the application data I found that the accounts were corrects and back to 28 which is today.

But in the accounts list and in the users account there was a problem, I restarted the game and the problem was fixed!!!

Do you have any clues about this problem? and what can I (you) do to prevent this problem from happening in the future and thank God the time this happen was not in a busy time. and is there any tool to back up the game at a specified interval of time/date


Poker Mavens version is 2.82

Regards
khaznadar
 
Posts: 9
Joined: Tue Jan 19, 2010 4:29 am

Re: Wierd Problem !

Postby Kent Briggs » Fri May 28, 2010 9:26 am

khaznadar wrote:Do you have any clues about this problem?


Did you change the "Data folder" setting in the Server Settings group? Or did you log into a Windows sessions and start the poker server under a non-admin account that didn't have access to your specified data folder? If either of those things happened then the program was probably looking in the wrong place for the account files and was using an older set stored in some other folder. Search all your local drives for a folder named "Accounts" and make sure there aren't more than one containing Poker Mavens .dat files and that your Data Folder setting is pointing to the parent of that folder, which should also contain several .xml files for Blacklist, BuddyLists, RingGames, and Tournaments.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3806
Joined: Wed Mar 19, 2008 8:47 pm

Re: Wierd Problem !

Postby khaznadar » Sun May 30, 2010 10:07 am

I think that was because of multi remote session made to the VPS container

The problem is solved now anyway, but I freaked out I was going to shut down my business !

Anyway, is there any autmatic backup of all the data folder? or should I code one from scratch?


Regards
khaznadar
 
Posts: 9
Joined: Tue Jan 19, 2010 4:29 am

Re: Wierd Problem !

Postby Kent Briggs » Sun May 30, 2010 12:26 pm

khaznadar wrote:Anyway, is there any autmatic backup of all the data folder? or should I code one from scratch?


You are responsible for backing up your data, preferably to an offsite location. There's no backup built into the system.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3806
Joined: Wed Mar 19, 2008 8:47 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 4 guests

cron