Page 1 of 1

having issues with Safari

PostPosted: Thu Mar 02, 2017 3:00 am
by ftpjesus
Anybodyelse having issues with Safari logging into their sites?? Ive tried directly connecting and even tried through my regular website.. All I get is a connecting thing and no login.. No issues as such with MS EDGE, IE or Chrome on my desktop..

Re: having issues with Safari

PostPosted: Thu Mar 02, 2017 10:19 am
by Kent Briggs
ftpjesus wrote:Anybodyelse having issues with Safari logging into their sites?? Ive tried directly connecting and even tried through my regular website.. All I get is a connecting thing and no login.. No issues as such with MS EDGE, IE or Chrome on my desktop..


Safari on a Mac or Safari on a Windows machine? If it's the latter, Apple abandoned the Windows version of Safari years ago at version 5.1.7, before they fully implemented websockets in version 6.

Re: having issues with Safari

PostPosted: Thu Mar 02, 2017 5:02 pm
by ftpjesus
Kent and I have emailed back and forth some and the issue is isolated to private mode with Safari in IOS. Not sure where the problem is could be Safari in private mode may have websockets blocked for some reason..

Re: having issues with Safari

PostPosted: Sat Mar 04, 2017 6:09 pm
by Kent Briggs
The issue turned out to be the way Safari handles "localStorage", where local settings like your login credentials, table and sound settings, etc. get saved. In private browsing mode, any attempt to save a value in localStorage fires an exception in the Javascript code (instead of just ignoring it) and was crashing the client. Anyway, I've got a test coded for this now and it will be fixed in the next update.

Re: having issues with Safari

PostPosted: Wed Mar 22, 2017 4:56 pm
by Kent Briggs
This bug is now fixed in 5.13