having issues with Safari

Report bugs found in Poker Mavens

having issues with Safari

Postby ftpjesus » Thu Mar 02, 2017 3:00 am

Anybodyelse having issues with Safari logging into their sites?? Ive tried directly connecting and even tried through my regular website.. All I get is a connecting thing and no login.. No issues as such with MS EDGE, IE or Chrome on my desktop..
ftpjesus
 
Posts: 21
Joined: Fri Dec 30, 2016 1:54 am

Re: having issues with Safari

Postby Kent Briggs » Thu Mar 02, 2017 10:19 am

ftpjesus wrote:Anybodyelse having issues with Safari logging into their sites?? Ive tried directly connecting and even tried through my regular website.. All I get is a connecting thing and no login.. No issues as such with MS EDGE, IE or Chrome on my desktop..


Safari on a Mac or Safari on a Windows machine? If it's the latter, Apple abandoned the Windows version of Safari years ago at version 5.1.7, before they fully implemented websockets in version 6.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3788
Joined: Wed Mar 19, 2008 8:47 pm

Re: having issues with Safari

Postby ftpjesus » Thu Mar 02, 2017 5:02 pm

Kent and I have emailed back and forth some and the issue is isolated to private mode with Safari in IOS. Not sure where the problem is could be Safari in private mode may have websockets blocked for some reason..
ftpjesus
 
Posts: 21
Joined: Fri Dec 30, 2016 1:54 am

Re: having issues with Safari

Postby Kent Briggs » Sat Mar 04, 2017 6:09 pm

The issue turned out to be the way Safari handles "localStorage", where local settings like your login credentials, table and sound settings, etc. get saved. In private browsing mode, any attempt to save a value in localStorage fires an exception in the Javascript code (instead of just ignoring it) and was crashing the client. Anyway, I've got a test coded for this now and it will be fixed in the next update.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3788
Joined: Wed Mar 19, 2008 8:47 pm

Re: having issues with Safari

Postby Kent Briggs » Wed Mar 22, 2017 4:56 pm

This bug is now fixed in 5.13
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3788
Joined: Wed Mar 19, 2008 8:47 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests

cron