Page 2 of 3

Re: Server crashing after the windows update

PostPosted: Sun Jun 07, 2015 5:37 pm
by Kent Briggs
mantux5 wrote:Well... It worked for like an hour and a half. Same again, everything is working like always, except for the API. It takes 4 to 6 seconds to respond. And I have no idea what might be the cause of this issue.


Have you closed it down and restarted since the Windows update? If not, try that.

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 3:21 am
by mantux5
Kent Briggs wrote:Have you closed it down and restarted since the Windows update? If not, try that.


Yes, I tried. After starting the server, now everything seems to be working quite good, but after some time API starts lagging (Maybe because of usage? But we had much more requests before and everything was fine)

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 9:10 am
by Kent Briggs
mantux5 wrote:but after some time API starts lagging (Maybe because of usage? But we had much more requests before and everything was fine)


Which API calls are being made and how often (according to the Event Log)?

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 10:13 am
by mantux5
Kent Briggs wrote:Which API calls are being made and how often (according to the Event Log)?


Mostly AccountsGet to fetch the balance information of the user. While noone is connected, it is shown to be executed like every 4 to 5 seconds, as there are still some users on the webpage, which has AJAX requests going. When the server is populated with people, there are multiple requests each second.

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 10:34 am
by mantux5
And now the server just crashed. I added some loading dialogs, so it was somehow usable even with a long taking API requests, but now it crashed... Again. We had like 10 or even more crashes while using your software (a little more than 2 months)

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 11:38 am
by Kent Briggs
Is there anything recorded in the error log?

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 11:56 am
by mantux5
There are bunch of these lines:

2015-06-08 18:34:52|WSServerExecute error: Access violation at address 0075F996 in module 'PMServer.exe'. Read of address 00000004

each occurring at 4-6 seconds period. All of them have exactly the same information concerning the addresses. However, there is one (the first one) with the Access violation at address 0075F9AF


Also, one error which occurred earlier (This did not cause any crash): 2015-06-08 03:58:16|KillInactiveSessions error: Socket Error # 10054

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 12:29 pm
by Kent Briggs
Are you running Pro or Gold edition? Version 4.39?

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 12:50 pm
by mantux5
Pro 4.39

Re: Server crashing after the windows update

PostPosted: Mon Jun 08, 2015 2:07 pm
by Kent Briggs
mantux5 wrote:Access violation at address 0075F996


I found the code where this address is. It may or may not have anything to do with your issues but I see a potential problem there so I'll clean that up and put it in 4.40 later this week.