Page 1 of 1

Last Action in the Connections tab appears nonfunctional

PostPosted: Fri Sep 26, 2014 1:51 am
by Raventhon
I have yet to see someone with a Last Action more than about 2 minutes in the past, even when I'm monitoring connections that I know haven't taken actions. What's "last action" determined by?

Re: Last Action in the Connections tab appears nonfunctional

PostPosted: Fri Sep 26, 2014 9:20 am
by Kent Briggs
Raventhon wrote:I have yet to see someone with a Last Action more than about 2 minutes in the past, even when I'm monitoring connections that I know haven't taken actions. What's "last action" determined by?


Last Action is updated with the current time when it receives a packet from the client. It's used in conjunction with the "Max idle minutes" setting to boot idle connections. If you load the client and stop clicking on anything, the Last Action time will stop updating.

Re: Last Action in the Connections tab appears nonfunctional

PostPosted: Fri Sep 26, 2014 6:11 pm
by Raventhon
Kent Briggs wrote:
Raventhon wrote:I have yet to see someone with a Last Action more than about 2 minutes in the past, even when I'm monitoring connections that I know haven't taken actions. What's "last action" determined by?


If you load the client and stop clicking on anything, the Last Action time will stop updating.


Loaded client, watching Connection tab, hand off my mouse, no input to my computer at all - the Last Action time is still updating.

Re: Last Action in the Connections tab appears nonfunctional

PostPosted: Fri Sep 26, 2014 6:37 pm
by Kent Briggs
Raventhon wrote:Loaded client, watching Connection tab, hand off my mouse, no input to my computer at all - the Last Action time is still updating.


I'm not able to reproduce this. I loaded the client and logged in on my local system and observed a running tournament. The Last Action field didn't update until I closed the table.

Re: Last Action in the Connections tab appears nonfunctional

PostPosted: Fri Sep 26, 2014 8:11 pm
by Raventhon
Kent Briggs wrote:
Raventhon wrote:Loaded client, watching Connection tab, hand off my mouse, no input to my computer at all - the Last Action time is still updating.


I'm not able to reproduce this. I loaded the client and logged in on my local system and observed a running tournament. The Last Action field didn't update until I closed the table.


I don't really know what to tell you - I'm looking at the set of connections live and most of them are constantly updating even though the people are definitely not active. If you'd like to connect to my site and take whatever set of actions you take that should result in Last Action not updating, I'm fairly sure I can demonstrate that it is updating. Are there some Mavens system options that would cause this?

Re: Last Action in the Connections tab appears nonfunctional

PostPosted: Fri Sep 26, 2014 8:19 pm
by Raventhon
Which browser are you using? It seems that certain browsers behave differently for Last Action. I'm able to successfully make it stop updating when I use Firefox, but Chrome seems to send packets back and forth on a fairly regular basis and I can't get a Chrome connection to report a Last Action more than about a minute in the past.

Re: Last Action in the Connections tab appears nonfunctional

PostPosted: Fri Sep 26, 2014 10:37 pm
by Kent Briggs
Raventhon wrote:Which browser are you using?


I was using Mozilla SeaMonkey (same engine as FireFox). I'll try again using Chrome.