PM2SIntall error in W2012 Server

Report bugs found in Poker Mavens

PM2SIntall error in W2012 Server

Postby fcisco » Fri Jan 24, 2014 4:42 pm

Hi Kent,

We have PM 3.15 installed and working a long time ago, but for some reason the session is being closed randomly. This started a like month ago. I've checked the session RDP configuration and the session timeout is set on "Never".
As I cannot find the solution to this behaviour, I think that would be a good work-around install PM as a windows service.

I followed the instructions in http://www.briggsoft.com/docs/pmavens/U ... tm#service
opened a command line as administrator and execute PM2sInstall.bat (in the same folder PM3 is installed).

The issue is that Im getting an error (screenshot attached) saying:
"Exception EOSError in module PM2Service.exe at 000112f9.
System Error. Code: 5.
Access is denied."

:o

We are using PM 3.15, and our server is a Windows Server 2012 Standard 64bits.

Do you know what should I do in order to proceed with the service installation?

Thanks in advance.
Attachments
service install error.png
service install error.png (6.78 KiB) Viewed 12262 times
fcisco
 
Posts: 1
Joined: Fri Jan 24, 2014 4:22 pm

Re: PM2SIntall error in W2012 Server

Postby Kent Briggs » Fri Jan 24, 2014 5:06 pm

fcisco wrote:We have PM 3.15 installed and working a long time ago, but for some reason the session is being closed randomly. This started a like month ago. I've checked the session RDP configuration and the session timeout is set on "Never".
As I cannot find the solution to this behaviour, I think that would be a good work-around install PM as a windows service.


You don't need to leave the RDC session open. Just click the X to disconnect. As long as you don't logout the Windows session, Poker Mavens will keep running. Converting to a Windows service is in the plans but I have to first get rid of the Windows GUI and convert it HTML5 like I did with the client UI.

The issue is that Im getting an error (screenshot attached) saying:
"Exception EOSError in module PM2Service.exe at 000112f9.
System Error. Code: 5.
Access is denied."


I'll see if I can duplicate that. That service program is a big hack anyway, I don't really recommend using it.
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3908
Joined: Wed Mar 19, 2008 8:47 pm

Re: PM2SIntall error in W2012 Server

Postby Kent Briggs » Fri Jan 24, 2014 5:13 pm

Are you sure that command line had Administrator rights? I found a similar report here:

http://stackoverflow.com/questions/10393154/how-do-i-find-out-why-i-am-getting-an-eoserror-code-5-access-denied-registerin
Kent Briggs - [email protected]
Briggs Softworks - http://www.briggsoft.com
Kent Briggs
Site Admin
 
Posts: 3908
Joined: Wed Mar 19, 2008 8:47 pm


Return to Bugs

Who is online

Users browsing this forum: No registered users and 5 guests

cron